=Sverweis(): Grundpfeiler der Automatisierung in Excel

Der SVERWEIS

Der Sverweis wird benutzt um nach einem Wert in einer Tabelle zu suchen, und anschliessend diesen Wert, oder einen Wert in der gleichen Zeile zurückzugeben. Die Sverweis Formel ist für mich ein Grundpfeiler für die Automatisierung in Excel. Sämtliche Berichte welche erstellt werden müssen enthalten mindestens eine oder mehrere Sverweis Formeln. Wer eine Tabelle automatisieren will mit Formeln merkt sehr schnell: am Sverweis führt nichts vorbei.

Fangen wir nun also mit der Erklärung dieses Grundpfeiler der Automatisierung an.

Formel Syntax erklärt

Die Syntax der Formel sieht in Excel so aus:

=SVERWEIS(Suchkriterium; Matrix; Spaltenindex; [Bereich_Verweis])

Hier nun eine einfache Erklärung was es mit der Syntax genau auf sich hat:

=SVERWEIS(“Was man sucht”;”die Matrix in der man sucht”;”die Spalte in der das Resultat steht das ausgelesen wird”;”ob das genaue Suchkriterium gefunden werden soll”)

An dieser Stelle müssen wir noch erwähnen dass die Matrix die man ausliest in der ersten Spalte immer den Suchbegriff enthalten muss. Mit der Sverweis Formel wird nur diese erste Spalte senkrecht durchsucht bis der Suchbegriff gefunden wird.

1. Beispiel:

Hier das erste Beispiel in dem wir aus einer Tabelle automatisch die Grösse einer Person ermitteln. Die Namen, in diesem Fall unser Suchkriterium, sind in der ersten Spalte senkrecht angeordnet, während die jeweilige Grösse der Person in der zweiten Spalte daneben steht.

sverweis Formel

Sverweis Formel

 

 

 

 

 

Die Formel in diesem Beispiel wird also wie folgt lauten

=SVERWEIS(C4;A2:B5;2;0)

und wenn wir das in Worte fassen, würde es sich etwa wie folgt lesen:

SVERWEIS(Suche den Namen “Marcel” in der ersten Spalte der Matrix A2:B5 und
dort wo es gefunden wurde, zeige an was in der 2. Spalte steht.)

Aufgepasst:
Wenn das Suchkriterium und der Wert in der Matrix exakt übereinstimmen sollen, muss eine 0 (Null) im [Bereich Verweis] gesetzt werden. Wird eine 1 geschrieben oder auch gar nichts, wird der nächst kleinere Wert angezeigt. Mit anderen Worten, Excel gibt den nächst kleineren Wert zurück den es findet. In einer unsortierten Liste kann es so schnell zu Fehler kommen. Ich empfehle immer eine 0 in optionalen [Bereich_Verweis] zu schreiben, es sei denn man will das bewusst nicht eine exakte Übereinstimmung für das Suchkriterium haben. Was meine ich damit?

Schauen wir uns ein zweites Beispiel an um ein wenig Licht in die Sache mit dem [Bereich_Verweis] zu bringen.

2. Beispiel:
Anhand von einer Bestellmenge soll der richtige Rabatt ermittelt werden. In diesem Beispiel stellen wir den [Bereich Verweis] auf 1 und suchen nach einer Bestellmenge von 11 Einheiten um den richtigen Rabatt zu ermitteln. Wir machen das weil wir nicht jede erdenkliche Bestellmenge angeben wollen, sondern einfach nur Schrittweise den Rabatt erhöhen wenn eine bestimmte Bestellmenge erreicht ist.

Formel Sverweis 2

Formel Sverweis

 

 

 

 

 

In diesem Beispiel suchen wir den Rabatt für eine Bestellung von 11 Einheiten. Die genaue Anzahl 11 wird in der Tabelle nicht aufgeführt. Wir haben aber definiert dass die Formel uns den nächst kleineren Wert liefern soll, in dem wir den [Bereich_Verweis] eine 1 gesetzt haben, so liefert Excel uns nun die Antwort 5% welche gültig ist bei Bestellungen ab 10 Einheiten.

Die Formel lautet in Excel nun:

=SVERWEIS(C4;A2:B5;2;1)

Wer die Sverweis Formel kennt kann auch die Wverweis Formel einsetzten. Was sind die häufigsten Aufgaben für die Ihr die Sverweis Formel benutzt?

Comments

Leave a Reply