Gültigkeitsprüfung für Dropdown-Liste

image

Vor kurzem wurde ich gefragt wie man eine Dropdown-Liste mit einer Gültigkeitsprüfung verbindet, so dass die Dropdown-Liste nur unter gewissen Bedingungen angezeigt wird. Das ist machbar und auch gar nicht so schwierig!

Die Werte Dropdown-Liste welche man dem User zur Auswahl geben möchte wird im Namens-Manager zuerst erfasst – z.B. als “Liste”. In unserem Beispiel (hier die Datei mit dem ) sind das die Zellen B3:B6.

SNAGHTML8aa804

Mit Daten Menü>Datenüberprüfung>Datenüberprüfung… rufen wir das unten angezeigte Fenster auf und wählen in Einstellungen>Gültigkeitskriterien unter Zulassen “Liste” aus.

SNAGHTML8d454c

Als Quelle benutzen wir eine Formel anstelle eines einfachen Zellbereiches (die obige Datenüberprüfung entspricht der aus Zelle E4 im Beispiel):

=WENN(D4<>””;Liste)

Die Formel macht eine einfache Prüfung ob der Namen des Verkäufers eingegeben wurde bevor es die Region als Dropdown zur Auswahl zulässt. Das dritte Argument der WENN Formel wurde weggelassen da wir bei einer FALSCH Auswertung keine Werte anbieten wollen.

Wählen wir nun eine Zeile an in unserem Bericht der noch keinen Verkäufernamen erfasst hat, so kommt zwar das Dropdown-Symbol, lässt jedoch keine Auswahl zu.

Comments

  • Guten Tag Lukas

    Ich konnte schon viel lernen auf Deiner Website, besten Dank.
    Aktuell prüfe ich die Möglichkeit, aus einer Tabelle mit einer Spalte Automarke und einer Spalte Automodelle zwei Dropdowns zu erstellen, wobei das erste Dropdown Automarke die gültigen Werte des zweiten Dropdown Automodell dynamisch reduzieren soll.

    Hast Du Dich damit auch befasst und allenfalls eine Hilfestellung? Das wär cool!
    Besten Dank und Grüsse
    Lukas

    LukasMarch 10, 2016

Leave a Reply