Quick Tipp: Dynamische Summen

image

Will man einen fortlaufenden Bereich summieren, ohne dass man dabei gleich eine ganze Hilfsspalte einfügen will, so benötigt man dynamische Formeln die Werte anhand Ihrer eigenen Position berechnen.

Dynamische Summen Formel

Mit diesem kleinen Trick könnt Ihr die SUMME Formel dynamisch machen:

Ersetzt den zweiten Teil der Zellenreferenz mit einer INDEX Formel!

=SUMME(B$2:INDEX(B:B;ZEILE()))

Nun wird der rot hinterlegte Bereich (im Bild) kalkuliert. Die Formel kann nun nach belieben kopiert und eingefügt werden in der Spalte C. Sie wird immer bis zur aktuellen Zeile die Summe kalkulieren!

Hinweis: Die Formatierung im Bild dient lediglich der Erklärung!

Wie funktioniert das?

Sie Summen Formel wertet die Zellenreferenz welche eingegeben wird zuerst als Matrix aus, dann erst werden die Werte in diesem Matrix summiert. Dieses Wissen hilft, denn so können wir die Matrix Berechnung vor dem zweiten Schritt beeinflussen. Hier bietet sich also die Möglichkeit die Summe dynamisch zu machen!

Wenn Dir dieser Excel Tipp geholfen hat, dann wird Dir mein Buch 101 Excel Tipps für Power User noch viel mehr helfen!

Comments

  • Einfacher geht das auch indem man den ersten Teil eines Bezuges mit F4 absolut setzt => =Summe($B$2:B8) Wenn man die Formeln in C8 einfügt

    kopiert man jetzt die Formel nach unten bleibt, die B2 als Startwert, allerdings wird nun bis zur aktuellen Zeile summiert.
    kürzer Formel und für Laien besser zu verstehen

    AnonymousOctober 22, 2013

Leave a Reply