=Wverweis(): der kleine Bruder vom Sverweis

Der Wverweis

Wer bereits die Sverweis Formel kennt wird mit dem Wverweis keine Probleme haben. Der Wverweis ist genau so versatil wie der Sverweis, wird jedoch weniger eingesetzt, einfach deshalb weil wir uns gewohnt sind die meisten Listen von oben nach unten aufzubauen; sprich senkrecht anstatt wagerecht.

Wie funktioniert denn nun der Wverweis und für was ist die Formel gut?

Das “W” im Wverweis steht für Wagerecht. Während der Sverweis also Senkrecht nach einem Ergebnis sucht macht der Wverweis dies horizontal und sucht ein Ergebnis entlang einer Zeile. Die Formel wird eingesetzt um Werte in Tabellen zu finden die Horizontal angelegt sind.

Formel Syntax erklärt

Die Syntax der Formel sieht in Excel so aus:

=WVERWEIS(Suchkriterium; Matrix; Zeilenindex; [Bereich_Verweis])

…welches in Worten so erklärt werden kann…

=WVERWEIS(“Was man sucht”;”die Matrix in der man sucht”;”die Zeile in der das Resultat steht das ausgelesen wird”;”ob das genaue Suchkriterium gefunden werden soll”)

Ähnlich wie bei der Sverweis Formel muss das Suchkriterium in der ersten Zeile der Matrix stehen!

Hier nun unser Beispiel!

In diesem Beispiel wollen wir die Grösse einer Person finden. Die erste Zeile enthält die Liste der Personen welche wir durchsuchen und die zweite Zeile die Grösse der jeweiligen Person; sprich das gesuchte Resultat welches die Formel ausgeben soll.

Wverweis Formel

Beispiel Wverweis Formel

 

 

 

 

Suchen wir nun also nach Stefanie, so steht in der Zelle E4 in Excel folgende Formel…

=WVERWEIS(E3;B1:E2;2)

Die Formel in Worte gefasst lautet…

=WVERWEIS(Suche den Namen “Stefanie” in der ersten Zeile der Matrix B1:E2 und dort wo der Name gefunden wird, zeige an was in der 2. Zeile steht.)

So sehen wir das Stefanie 177 cm gross ist.

Hier noch die Datei mit dem WVerweis zum selber anschauen!

Wann und wo setzt Ihr die Wverweis Formel am meisten ein?